A fix has been implemented and we are monitoring the results.
Posted Jul 24, 2025 - 13:36 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 24, 2025 - 11:27 UTC
Investigating
Calculated product stock levels and sales graph related updates in our user interface will take longer than usual to appear, affecting forecast/safety/order up to stock levels and sales graph.
Posted Jul 24, 2025 - 08:22 UTC
This incident affected: Application (User Interface).