Exact Online Premium is not available

Incident Report for Optiply

Resolved

This incident has been resolved.
Posted Dec 02, 2024 - 11:28 UTC

Investigating

Exact Online is currently investigating the issue.
Posted Dec 02, 2024 - 11:04 UTC
This incident affected: Integrations (Exact Online).